Bug Fixes for Game Update

White Giant RPG Studios Forums Last Dream Forum Bug Fixes for Game Update

This topic contains 31 replies, has 7 voices, and was last updated by  whitney 6 years, 2 months ago.

Viewing 10 posts - 21 through 30 (of 32 total)
  • Author
  • #1865

    Andrew Walker

    vgn-larrymac: I’m sorry that you’ve also experienced this bug. We haven’t yet released a game update but I plan to sometime in the next week. In the meantime, I can fix your save file, if you’d like.

    To get your save file fixed, please follow the following instructions:
    1) Navigate to the “parent” folder of the Last Dream installation folder (C:\Program Files (x86))
    2) Locate the “Last Dream” installation folder.
    3) Right click on the “Last Dream” folder and select “Properties” at the bottom of the list.
    4) Go to the “Security” tab (3rd from the left).
    5) Find the text “To change permissions, click Edit.” in the “Last Dream Properties” pop-up window.
    6) Click the “Edit” button just to the right of that text.
    7) For each of the groups or user names in the upper box do the following:
    a) Highlight the group or username in the upper box.
    b) Click the “Allow” box in the “Full Control” row of the lower box. It should check all other “allow” boxes.
    c) Click “Apply” in the lower right hand corner.
    d) A windows security box will pop up showing windows changing the permissions on all the files.
    8) Once you’ve done this for all of the groups and user names in the upper box, click “OK” in the “Permission for Last Dream” pop-up window.
    9) Click “OK” in the “Last Dream Properties” pop-window.
    10) Enter the “Last Dream” installation folder.
    11) Double-click on the “Game” application (denoted with unicorn head icon) to open Last Dream.
    12) While in-game, load up your current game.
    13) Save your game and then exit Last Dream. You should find a save file from the same slot in your installation folder (e.g. if you saved from slot #3, you will see Save3).
    14) Send the save file from your installation folder to info@whitegiantrpg.com.



    I couldn’t get the save file to show up for some reason, but if other people have this issue I loaded my save (it was slot 2) and then saved it in another open one (slot 4) and that file (save 4) then showed up. Weird.

    Anyway, I just sent the file. Will this just unflag the guard (or whatever) or is it going to back me up someplace like rescuing the hermit or something? Thanks and looking forward to continuing on my way!


    Andrew Walker

    Yeah, that makes sense. The save files are hidden in some deep dark place due to the permission restrictions in the Program Files that doesn’t allow for the creation of new files. The save files all exist but they can’t be created as “hard copy” files until the permissions are changed.

    I received your save file and I’ll try to send it back to you during my lunch today (in ~4-5 hours). Regarding your question about how the fix will affect you: You’ll be at exactly the same location except the guard will be functioning properly. You won’t lose any progress.

    Sorry again for the bug. Comprehensive game testing is tough.



    Thanks, worked perfectly!


    Andrew Walker

    Glad to help.



    I just formatted my computer and when I play the game in fullscreen there’s a very serious flickering going on … unplayable. Altho I can play it in windowed, it’s not quite as satisfying.


    Andrew Walker

    Have you tried using F1 and the “reduce screen flicker” option?

    I remember that someone else had a similar problem and I believe that we were able to fix it. I’ll go back through my emails and look if the “reduce screen flicker” button doesn’t work.



    I just tried it …. didn’t work :/, and it’s happening before loading any saves.


    Andrew Walker

    I looked back through my previous e-mails and here is what I found:

    Generally, the error is due to hardware acceleration. Try following the instructions here to see if this works for you:


    If that doesn’t work, it’s likely a problem due to DirectX. Try installing the latest version or it’s specific to your video card. If none of the earlier items work, let me know what video card you’re using.



    The change settings is grayed out … what to do? I got Intel(R) HD Graphics 3000

    EDIT: Oh, gonna install directx, might be why … since I just formatted O.o, hold a few minutes.

    Nope, not working 🙁

Viewing 10 posts - 21 through 30 (of 32 total)

You must be logged in to reply to this topic.